Problem with Case Conversion of Filename (tag is ok)

I am a somewhat experienced user. Not sure what's going on here...

Have a typical folder full of MP3s. Do my usual cleanup to it, including Case Conversion. All looks ok, including the Filename field. But when I actually look at the filenames in Explorer, they are still lower case (technically, they are still as before, not changed). I've refreshed, I've dbl checked properties (not read only), yada yada.

Then I tried changing the case in Explorer (F2 key). It won't work either, telling me it's probably not Mp3tag, but something in Windows?

Thought I would ask here just in case. Thanks!


This indicates that this is not a Mp3tag problem.

You can check such files if there is a read-only-attrib set, visible in File Explorer in Properties.

If not: Is this a local folder or something reachable from a NAS or external storage?

see e.g. here:

Thanks for the replies. I'm fairly certain it is NOT an Mp3tag issue, since I can't change it directly in Explorer via F2. It's not a NAS. Not read protected.

BINGO! The answer is in the reply in that thread you linked, from JJ_Johnson. This is a Windows bug, going back at least ten years+. I'll cut & paste for future reference...

To elaborate, again for future reference: I had updated the filenames per my usual naming system. After which I realized I had some case issues, and ran case conversion. Then updated filenames again. It looked like it worked (in Mp3tag display), but it didn't. Explorer still showed the case issues. Reloading in Mp3tag also showed it again.

The answer is to correct the case FIRST. Then rename filenames.

Thanks for your replies and help on this mystifying issue.

1 Like

Just out of interest as I have been doing some research on this recently myself: on what file systems are the affected files on, FAT32 or NTFS? In my testing renaming case only not working affected only FAT32. And what version of Windows are you using?

Win10, latest version (I keep it updated). It happens on both xFAT and NTFS.

1 Like

Interesting, thanks. Windows can be odd. I haven't tested exFAT yet, will try this. But on NTFS I can do case changes.

Your post made me go back and take a second look, I was wrong. On my NTFS, case changes DO stick. That's my internal hard drive.

On the external drive (a USB thumb), it doesn't stick. exFAT.

1 Like

Thanks. I now also tested with exFAT, and I share the same experience of renaming not working. Not with Explorer nor tagging applications Mp3Tag or Picard. I actually researched this just recently for Picard, as we face exactly the same issue there. I'm wondering if it is worth implementing a workaround of automatically double renaming the file. Not sure if Florian would also be interested in such a (admittedly kind of hacky workaround) for Mp3Tag or if the argumentation rather is "Windows can't do it also".

But then you can do it yourself.
Create an action group that has an action of the type "format value" for _FILENAME with
Format string: %_filename%_
which adds an underscore to the filename. And then you apply the case conversion.

1 Like