Release Date info not showing in ipad or ipod?


#1

I'm having this problem and i can't fix it..
i used tagMp3 to embed the release date into my songs using this format YYYY-MM-DDThh:mm:ssZ and the release date showed up right in itunes, however it does not show in iPod or iPad.. how can i fix this??


M4a iTunes Release Date Using Mp3Tag
release date help on itunes m4a files only
How to tag full releasedate to view on iphone?
ITUNESPURCHASEDATE
#2

I don't think so. iDevices are somewhat more limited in their tag usage & display characteristics than iTunes is. The tag is still there in the metadata, but those devices may just ignore it by default. Or if the tag shows but in a truncated format, then that's just the date display format those devices use.

Release date information doesn't actually include hh:mm:ss data, does it? I'm just wondering what would be the utility of that information..... :frowning:


#3

but when i purchase music of the iTunes store it comes included with release date and it does actually show up in iPod under the album name!

yeah i think some songs comes with that detailed info as well..but yeah it's not really that important


#4

Can you show a screenshot of that ? I buy all my music from the iTunes store and I have never seen that.

In my iPods I see under the album the rating (stars) and nothing else


#5

ok here's one


#6

Thanks for that !!

Could it be that it gets that date from the Purchase Date ?

in Mp3tag called: ITUNESPURCHASEDATE


#7

i edited that tag also and it did not change...thank you for suggesting!!
i've tried all sort of things i've even exported the tagging information of the purchased song and paste it into another not-purchased song and still won't show up


#8

hey!! i fixed the problem for anyone would need to know, if u have a song you want to tag it with the release date and the copyright information and want that info to show in iPod here's how:

-first tag the song with this tag (ITUNESPURCHASEDATE) using View>Extended Tags
and add any value you want as the purchase date e.g. (2011-09-14 05:58:30)
this will make the file behaves as a purchased file.

-then write the release date in the YEAR tag with this format YYYY-MM-DDThh:mm:ssZ
and if you want to add the copyright info too you can by adding the tag (COPYRIGHT) and write in the value you want.

i came to this after alot of tries and effort hope you'll find it helpful..!!

thank you all for your collaboration it's appreciated..


ITUNESPURCHASEDATE
#9

FYI, the T and the Z are literals. Z refers to Zulu time which is a reference to the time zone to which the 24-hour clock (used in military time) is assigned.

Not that you asked but iTunes dates ares formatted as Coordinated Universal Time or UTC, which you encounter in techie places. (If you're really curious about one person's confirming its use in iTunes, see http://www.joabj.com/blog/?p=814.) [And UTC is a compromise of the initials that allows the acronym UTC to work in both French and English.]

BTW, technically UTC is different from Greenwich Mean Time (GMT).


#10

Hey Anas,

I have the same issue. Are you're files in mp3? When I convert my files from mp3 to m4a than he shows the copyright tag on my iphone but not the release date..
I'm so stuck...
I don't have a tag like itunespurchasedate in my mp3tag..
Can you say what setting you use in intunes?
I checked the box manage music manually.

Can you please help me out?
Thxxx


#11

You just add the tag yourself. You're never limited to the tags that are already showing in mp3tag....you can add whatever you want.

  • Select the song or album you want to tag
  • Right-click, and choose Extended Tags...
  • Hit the little "star" icon to add a tag :mt_new:
  • In the pop-up dialogue box: Field = ITUNESPURCHASEDATE Value = yyyy-mm-dd hh:mm:ss
If you need to add this for a lot of songs/albums, it would probbaly be easiest to add this Field to your Tag Panel, so it's always visible & readily available.

In Post #8 above, anas described the exact steps that worked.


#12

tried with spyro the dragon video game soundtrack on itunes i did everything right but it still says released 1998 i put this in year 1998-09-10 T09:30:12Z and this in ITUNESPURCHASEDATE 1998-09-10 09:30:12 does it not always work because it worked one one album not on this one i will be uploading photos of my progress the spyro one is messed up and the cardcaptors one is fine




#13

Remove the space in the YEAR field:
1998-09-10 T09:30:12Z
-->
1998-09-10T09:30:12Z

and RELEASETIME is only for mp3


#14

I Have A Question How Long Will It Take To Creating The Tagging for Ipod To Work with It?

Or How Long Does it Take For It To Work


#15

It Worked On Clannad Soundtrack so i have a question For anas how long do i have to wait for the songs to show on the ipod? because i ran a test on a old adam sandler track and it worked i had to wait maybe 3 weeks and when i did clannad it work automatically you know


#16

The updating cycles on Apple products seem to follow very individual time spans.
Does the update show in iTunes? If not, press Ctrl-I to force-read the information. If this does not help, delete the entry from iTunes and reread the files.
Then remove the files from the sychronization playlist, synchronize and add them again.
Still, I'd say that this is more a question for an Apple forum.


#17

I noticed on iTunes purchased date comes up but when I sync the track to my iPod that's when it faileds


#18

And? have you deleted the updated tracks from the sync-list, synchronized and then re-established the sync-list?
E.g. iTunes never updates the "Compilation" entry: once a track has been identified as part of a compilation then it stays like that even if you delete the tag... so I would ask an Apple forum, why updated information does not show on an iPod.


#19

when i wrote this i was at work not near my laptop so i will check on that now


#20

can you show me how to do it?

i hit ctrl i and i give me the info on itunes and the purchased date comes up what do you mean by this

The updating cycles on Apple products seem to follow very individual time spans.

press Ctrl-I to force-read the information. If this does not help, delete the entry from iTunes and reread the files.
Then remove the files from the sychronization playlist, synchronize and add them again.