Save tags WITH MOUSE CLICK does not work, if value is SELECTED from existing ones IN PERSONALLY ADDED FIELDS of Tag Panel (2.88b)

2.88b, win7x64hun

3 files in the table. In tags' panel there is TOTALTRACKS (and a column, too). (But works -- I mean, does not work :smiley: -- with any other tag, too.) 2 of 3 files have the value 21, the first file has 3. I select all files, in left tags' panel select "21" value, then click with mouse on a blank part of the table. The value "3" of the first file does not change to "21".

But!
If I select only the first file, in the left panel write "21", then click on blank part -- the new value "21" is saved.
If I select all 3 files, in the left panel overwrite < keep > with "21", then click on blank part -- the new value "21" is saved.

Clicking on "Save" button works allways. Tried with vertical an floating panel too, no difference.

(In preferences, of course, I set the needed option. I never changed it. I think, the bug started with 2.88b.)

(And, in last some hours Mp3tag crashed about 5 times, with 3,000 files and with 26,000 files too, in different situations. In error log: allways some "sflac..." thing -- but I forgot it... When (if) repeats, I write it here.)

(And, in last some days. I have a long, about 3 times as app's window, tags' panel on the left side, vertically. I want to change something down, for example the cover. Click in it -- and the panel pops to the most up. And vica versa, too. Not all time, but frequently.)

You have to activate the option to save tags when navigating with cursor keys/mouse click.
See Tools>Options>Tags
It could be that if you have nowhere to navigate (as the selected files are the only ones to navigate to and clicking into the blank area does not trigger a navigation) nothing gets saved.

I would do the well-known checks with mp3val and/or mp3diags and see if the files are OK.
Also, I would check the file system. And repair any found errors.
You could then see if MP3tag still crashes.

I am not agree. Mp3tag works in another way, I remember exactly: that is enough to click on a blank part. My, now, does not save with clicking an a next file, with full table, too, of course.

Yes, may be, you are right. But both are time consuming acts. If crash repeats, I try them. (But I do not find it too likely, that this is the reason. Foobar2000 does not usually crash, while handling the same music files.)

I tried again 2.88a: it saves without problem.
Will anyone so kind, as to try
this on 2.88b, too? It is really uncomfortable.

I tried the following with 2.88b:
Opened a small folder with just 5 files, so there is plenty of white area (window background) in the files list.
Set the option in Tools>Options>Tags to save tags on mouse-click
Selected all the files.
In the tag panel: added an underscore to the artist name
Clicked on the windows background.
Message box tells me that 5 out of 5 files were modified, tag panel and files list show the added underscore for artist.

To me this looks allright.
(This was W7).

If manually added a new value (or manually overwrite with an old value), it works for me too. It does not work only in case, when I select an existing value, without manually writing:

< keep >
< blank >
3
21

Then I select 21. Click on blank part or on another record. The file's (1 of 3) previous value "3" is unchanged. In 2.88a it changes to 21. Can you try this, too?

I have to disappoint you:
I created the tag artist in 3 files, the first with "1", the second with "2", the third with "3" as data.
I select these files.
Dropdown list shows 1, 2 and 3.
I select "3" from the dropdown list for the field ARTIST.
I click on the window background.
A message tells me that 3 files got modified.
I see the "3" in all 3 artist fields.

What you could check: which tag types are in the files? Esp. APE tags lead to confusion.
If you have APE tags, get rid of them and see if you can now save all the data that you want.
To get rid of them, go to Tools>Options>Tags>Mpeg and enable for "Delete" only APE.
(and also disable to write APE tags, while you are at it)

Then select the files and cut the tags with the functions from the context menu.

I do not use them, use only Vorbis comments and ID3v2.3 utf-16, and use only 3 file types: flac, mp3 and opus. (But opus I all convert now to mp3 and send them to trash -- it is immature, unsolved type, leastwise for music.) I tried all variants of mixes (only flac, flac+mp3 and so on) -- no difference.

(But this all is, I am sure, indifferent. 2.88a works -- 2.88b does not. Nothing changed on my laptop, only Mp3tag version.)

BTW, and excuse for stupid question: did you check, you use really 2.88b? Simply because this all story is so strange for me.

The APE tags were just an idea - if you read but do not write them, it could be that you always see the old APE tags.
I am pretty sure that only very few people use APE - but they could have crept in. So it would be worthwhile to check.

Yes. even with a new installation. It works for MP3 files in my installations. So apparently, I cannot help you..

I'm accurate. I use constant Foobar and frequent Mp3tag filters, practically nothing can happen in my music files without my awareness. :smiley: So, there are no APE or any other tags.

Sorry. Anyway, thank you for your help.

One idea, but only a rough guess: can you check if you have multiple fields for TOTALTRACKS configured in the Tag Panel?

I checked it: no.
Now I try a total fresh, clean reinstall.

Uninstalled, installed a fresh 2.88b. Works well.

Gave back the old components one by one.
usrfields.ini seems to be the cause. After I played a little with checking/unchecking the visibility of personally added fields by the new feature, now ALL work normally. Tracktotal too.

May be, solved?

Do you happen to have the old version of the usrfields.ini? I'd be interested in analyzing the issue.

Before uninstall, I saved both, working and personal folders. After new install tried to change new files/folders with old ones (moved back old ones), one by one, in diagnostic purposes. Working folder back (PrF86): no problem. C:\Users\ItsMe\AppData\Roaming\Mp3tag\export and file mp3tag.cfg gave back: works well. Gave back C:\Users\ItsMe\AppData\Roaming\Mp3tag\data folder -- the previous defect started again. Replaced again the data folder with new one (from new install -- first I backed up it too), and started gave back files of the old folder, one by one. The first file was usrfields.ini, and the problem started right again. Then I leaved this old one working, but tried in the program check-uncheck the visibility, and slowly healed himself. I did not do anything else.

OK, that's magical indeed.

I'm moving this to #bug-reports:no-bugs for the time being. Please let me know in case it happens again.

All right, I shall do it. And thank you for your attention.
A moment, I forgot to notice: earlier, when you constructed the new feature with visibility checking of Tag Panel individual fields, I manually add to the end of usrfields.ini the rows:

[#22]
value=COMMENT
name=Jegyzet
multiline=1
enabled=0

The idea was from forum (to have multiline COMMENT field), but I use it rarely, besause it do not let to use the standard (one line) COMMENT field (they interfere). And multiline fields do not let me to copy one field with method, mentioned in the topic start. The numeration ([#22]) was correct.

2.88d: the problem still exists.
(And the behavior is not associated with _SEPARATOR. Some fields work, some not.)

Thanks! Can you try with the latest Development Build Mp3tag v2.88e?

Yes -- I yet trying. The nuance: the new "Save config" of Tag Panel opens the working folder (Program Files -- Win7), not the personal (C:\Users...), so in File >> Backup your settings these files will not included.

Later: ...or open any else folder -- it seems not to be regulated, as for columns' saves.

You can create a panels directory in your user directory — it should open there then. I'll create that directory by default with the next release (similar to the columns directory).

1 Like