Some MP4 files are not listed when starting from context menu

I have ensured that the download executed properly, restarted my PC, and everything else looks fine but if I right-click on an mp3 and select MP3 Tag, it brings up the screen but with no file selected. If I change directories to see files, it only shows those files that already have MP3 Tags.

Could it be that you have applied a filter?
Press F3 to toggle the filter and see whether the files that you expect will appear.

Nope. F3 shows no filters applied.

It could be that you have just a space as filter.
That is why I asked whether the number of files in display changed.
Also, you can see in the statusbar at the bottom how many files are loaded and how many are displayed.

I can't duplicate this, on two different machines. Both are Win10 x64 and have v3.20 installed. I have tried different music file types (mp3/flac/m4a) using right click on files and folders, as well as from within mp3tag. All files are opening and displayed as expected.

You mention only files open that already have tags. So the ones that don't show up I assume are newer files, and have no tags at all? Do you at least have a column for "Filename" so something can show up?

Yes, I have the filename column first--everything is in the default configuration. It will respond normally and display the filename of files that have an existing tag, but not those that don't.

If untagged, I get 0 files loaded and 0 displayed. Is it possible that the program rejects filenames with parentheses or other marks that Win10 accepts?

MP3tag does not load e.g. mp4 files that have an unsupported format

MP3TAG will typically at least list files, even if they have corrupt headers. But perhaps there is something else wrong. Perhaps a check of the file integrity is needed?

Otherwise perhaps you can share a file here to be looked at?

Thanks! I will take some time with that when I can and see what it can identify. All of the files play fine on common programs like default Windows players and JRiver Media Center, so I assumed that meant that the formats / format info had to be good enough to make them usable.

That files "play" does not mean that they are OK.
If you are fine with just playable files then you can stop here. Otherwise, you have to some more investigation.

Can you post a screenshot of one folder listed in Mp3tag and Windows Explorer which shows the issue?

This probably isn't the best example since it is mostly MP4, but it's the one I had up at the moment. MP3Tag sees a couple of them.

Yes, hard to tell what's with the files that are not listed. Can you share one of those?

I think I can show this as resolved. I ran into a suggestion elsewhere to re-containerize the files that weren't showing via the VLC "convert" function, and see if they then showed in MP3Tag, and that worked. The only thing that puzzles me a bit is why I had not had the issue with prior MP3Tag versions and it only came up after an update. In any case, that is not a problem that needs solving. Thanks for the input / help here.

OK, thanks for confirming

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.