Song cover not showing

i just updated mp3tag to v3.09 and edited some songs as usual, this time the cover is set but on the file it doesn't show anymore like the rest of the songs that i already have in the folder ..
note: when i play these new songs that their album art isnt showing, windows media player has difficulties to run them, but barely runs them at the end, they make the windows media player laggy and sometimes crashes and not responding a lot, although windows media player runs normally on the old songs, means as usual
any idea?

Did you change the way that you installed MP3tag (standard vs protable)?
What kind of files (flac, wav, mp3?) are these?
Have you checked the files whether they really have embedded covers? Or do you see only the picture file from the folder?

If you think that the files have problems in the audio part (which is not managed by Mp3tag), the check the files for integrity.

  1. no, i updated it like i do everytime, always pressing Next button (so standard i believe)
  2. mp3
  3. I added their cover (.jpg) like everytime in mp3tag and pressed Save, I see the picture when i open the song in the mp3tag, but not it see on the song file like the rest of the old songs.

how do i check the files for integrity?

I noticed that the problem comes from the website am using to convert youtube songs with (ytmp3.cc)
they may have made some updates and now am unable to set convers for the songs i convert them using their website..

Noticed that after trying to convert the same songs using another website (converto.io) and everything went well (I managed to add the cover like I always do)

Wish they fix that coz i like their website more coz its easier to use.

Thanks for ur guys help