sorting export result %_counter% bust?

I'm fairly sure in an Export config the line loop(%_counter%) used to produce lines in File List order. Now the list is in some jumbled order.

Is it possible that %_counter% got bust in a recent release?

Yes, I'll fix it to the next release.

Kind regards,
Florian

Thanks.

This has been addressed with the latest Development Build.

Kind regards,
Florian

Are you sure, Florian? Because here (Mp3tag v2.38a Jun 16 2007 22:00:33)
the problem persists.

This is the exact 'bug' i have just logged in to ask about. Tried the 'stable', and the 16th jun beta/dev build, both have the same issue.

Also, i can't convert the tags using the filename - tag option, the OK button is always greyed out.

i can't convert the tags using the filename - tag option, the OK button is always greyed out.

Though one might expect it to be available directly after loading some files, in order for it to be available one has to also select some files.

Yeah, i already knew that (otherwise, i would have been complaining about other options not working too). :stuck_out_tongue:

OK! :wink: Then I wonder what can be causing the command to be greyed...

Any chance of a fix Florian?

Please try again :rolleyes:

Still broken! E.g. compare line 3 of the mp3tag filelist with line 3 of the export output here:

No, it's sorting as strings.
You need to pad with zeros: $loop($num(%_counter%,5))

Whoops! I erroneously posted the bitmap from a different test. Now corrected. Thanks, Dano.

Fellow sufferers might like to know that reverting to V2.37a avoids this.
Florian might like to know that that reverting to V2.37b does not :wink:

PS Many thanks Florian for http://www.mp3tag.de/download/mp3tagversion.en.html .

Are you by chance applying this export file to more than 100 files? If so, you have to use
$num(%_counter%,3)

Kind regards,
Florian

Are you by chance applying this export file to more than 100 files?

Yes (101) but since $num(100,2) produces 100, that cannot explain the reported failure, surely.

If so, you have to use $num(%_counter%,3)

That doesn't fix it.

Before:

After:

Florian, is there anything else I can do to help you fix this?

Would you mind showing me screenshots of the test above with v2.39b?

Not at all - here it is:

The procedure was:

. 1 Launch mp3tag V2.39b
. 2 Drag in the folder Edgardo Donato\ (101 tracks)
. 3 Click file list column heading Title, then Track then Path, to get the list order.
. 4 Hit CTRL-A, CTRL-E, click OK, click Yes.
. 5 See that the output file's line 12 fails to accord with the file list.

By the way, the expected position of the track that appears at line 12 is line 101.

If you'd like the track files (332Kb), just ask.

We said you must use at least $loop($num(%_counter%,3)) for 100 tracks or more!
2 as parameter is not enough.