Startup | Boot Failure or Extreme Delay

I am running v. 3.00 on a Windows 10 Pro machine (with all updates installed).
When I start MP3Tag, the program does not appear anywhere on my screen. When I attempt to run it again, same result: Nothing.
When I check the task manager MP3Tag does NOT show as a running App, but I do see in the Background Processes, one instance of MP3Tag for each time I tried running the app.
Sometimes a reboot of my system helps; other times, not.
Very Frustrating.

UPDATE: After approximately 7 minutes (while I was typing this bug report), MP3Tag finally showed up on my screen. This has happened before, i.e., where it takes literally 5-10 minutes to appear on my screen.
The issue is not that I left it in a huge folder. For example in this case, it came up with the last folder I was working on it which had 14 files.

I have no such problems. I run MP3tag 3.00 on (W7,) W10, W8, data connection via USB, network or local.

Do you use the MP3tag library?
Where is the last folder located? Local drive, detachable drive, NAS?
Which other programs run at the same time and check the same program?
What kind of installation of MP3tag have you used? Standard or portable?
Do you use MP3tag in a migrated environment?