Taggen und Verwalten der Audiosammlung mit MP3tag

Hallo newser,

jetzt steh ich einfach im Wald und sehe die Bäume nicht, Meine Sortierung der Tracklist will einfach nicht so wie ich :flushed: (nfo.txt)
eigentlich wollte ich die Trackliste sortiert nach Track ausgeben aber leider bekomme ich es nur nach Filename bzw. Artist, was mach ich falsch oder wo kann und darf ich was ändern ?

vielen lieben Dank im voraus

Dieses Tool lässt mich nicht mehr los und ich sitze nun schon seit Tagen und sortiere meine Kompletten mp3's neu :laughing:

wichtig und nicht zu vergessen die Sicherung muss auch neu gemacht werden da sonst alles doppelt wäre.

Die Arbeit lohnt aber in jedem Falle da nur so auch eine einheitliche Sortierung möglich ist.

Hast du eventuell eine Beispiel nfo für mich?

Hallo newser,

habe mir erlaubt eine nfo.Datei ins Postfach zu legen

ich bekomm es nicht gebacken die Sortierung zu ändern und alle Versuche enden in eine Artist-Sortierung.

Danke im voraus

Danke newser,
genau das wars jetzt wird die .nfo auch nach Tracknumber sortiert und ich bin wieder ein glücklicher mp3ler.

Ersetze alle: $loop(%album%) mit $loop(%album%%albumsortorder%%track%)

Versuch die Erzeugung des COMMANDS-Strings zu vereinfachen: url: siehe erstes Posting

Ein kleines Upgrade

mtr, - Trackanzahl bei ausgeblendeter Trackliste in der nfo einblenden
nhy, - update: wirkt jetzt bei allen Ordnervarianten zwischen Year und Album.
nhy3, - entfernt Bindestrich zwischen Artist und Year bei Namensschema Artist - Year - Album.
vbr, - in der nfo wird die Bitrate in der Trackliste automatisch eingeblendet wenn in einem Album ein Track mit VBR gefunden wird oder wenn bei einem Album mit CBR nicht alle Tracks einen identischen Wert haben.
Bei gemischten Alben wird in der nfo jetzt CBR und VBR angegeben und nicht nur der erste gefundene Wert.
soa, - (show ORIGARTIST) in der Trackliste der nfo wird (ORIGARTIST) eingeblendet (nach Titel, vor (ORIGYEAR)).
brk1, - runde Klammern in den TAGS Album, Artist und Titel
brk2, - eckige Klammern in den TAGS Album, Artist und Titel
wpl, - wpl-Erstellung hinzugefügt (Windows Media Playlist)
plla, - bei Mehrfach-CDs in Unterordnern wird eine Playlist für alle CDs in der Parent Directory erstellt.
caps, - Schreibweise Normal für die TAGS Album, Artist, Genre, Titel, Origartist und Origalbum (1. Buchstabe je Wort gross) Grossschreibung nach Leerzeichen ( - _ . / " [ + &
caps2, - Schreibweise Normal für die TAGS Album, Artist, Genre, Titel, Origartist und Origalbum (1. Buchstabe je Wort gross; Grossbuchstaben werden beibehalten) Grossschreibung nach Leerzeichen ( - _ . / " [ + &
low2, - Kleinschreibung des TAGS WWW
rom, - Grossschreibung römischer Ziffern (thx 2 DetlevD)
nul2, - (no underline) Keine Unterstriche in den TAGS Album, Artist, Titel, Comment, Genre, Origartist, Origalbum, 'Album Artist' und Band
copf, - (copy file) kopiert Datei in den Albumordner
Führende Leerzeichen in der 2. Zeile der Trackliste werden jetzt entfernt.
Dateikopierfunktion integriert.

ich hab auch noch ne Frage zu diesen Aktion/Export

del_m3u-nfo-sfv.bat

ich wähle ein Ordner aus.
und wähle die dateien aus.
gehe. auf die Aktion und starte diese.
Die dateien werden dann über die bat auch gelöscht, leider befindet sich danach die bat im Ordner, das ist auch nicht der Hit das ich die manuell löschen muss.

Was mache ich falsch?

Gute Frage. Hast du irgendwo irgendetwas verändert?
Die .bat löscht zuerst .m3u, .nfo, .sfv, .pls, .wpl und dann sich selbst.

also ich habe die datei: del_m3u-nfo-sfv.bat.mta

[#0]
T=15
F=_del_m3u-nfo-sfv.bat
1=%_folderpath%_del_m3u-nfo-sfv.bat
2=0
3=1

in actions kopiert

und die _del_m3u-nfo-sfv.bat.mte

$filename(_del_m3u-nfo-sfv.bat)'@echo off & setlocal
del *.m3u
del *.nfo
del *.sfv
del *.pls
del *.wpl
del _del_m3u-nfo-sfv.bat

goto:eof'

in export kopiert.

muss ich mit dieser tools.ini
[#0]
MTTOOLSNAME=split pll
MTTOOLSPARAM=/C _split_m3u.bat
MTTOOLSPATH=C:\\Windows\\System32\\cmd.exe
MTTOOLSINST=1

[#1]
MTTOOLSNAME=copy file
MTTOOLSPARAM=/C _copy_file.bat
MTTOOLSPATH=C:\\Windows\\System32\\cmd.exe
MTTOOLSINST=1

[#2]
MTTOOLSNAME=del m3u,nfo,sfv
MTTOOLSPARAM=/C _del_m3u-nfo-sfv.bat
MTTOOLSPATH=C:\\Windows\\System32\\cmd.exe
MTTOOLSINST=1

also hauptsächlich [#2] irgendwie in die tools.ini integrieren?

ich hab *2 mal in meine tools.ini integriert.
jetzt habe ich nochmal getestet in dem ich alle Dateien selektiert habe und dann die del.... Aktion gewählt habe.

Danach in den Ordner geschaut. Es wurde nichts gelöscht nur die bat steht jetzt zusätzlich drin

Hat die .bat den korrekten Inhalt?

@echo off & setlocal
del *.m3u
del *.nfo
del *.sfv
del *.pls
del *.wpl
del _del_m3u-nfo-sfv.bat

goto:eof

Wie rufst du sie auf?

woher soll ich wissen ob die bat den richtigen Inhalt hat, habe ich hier im Thread runtergeladen.

rufe sie über die Aktion auf .mta
darüber wird dieexport mte aufgerufen.

In die .bat rein schauen und mit dem was ich ein Posting vorher in die code-tags gepackt hab vergleichen.

also ich
diese zeile drin

$filename(_del_m3u-nfo-sfv.bat)'@echo off & setlocal
hab so geändert
@echo off & setlocal

aber es funzt trotzdem nicht

hab sie hier rein kopiert
C:\Dokumente und Einstellungen\User\Anwendungsdaten\Mp3tag\export

könntest du vielleicht nochmal funzzende scripts dafür hochladen, dann würde ich die anderen entsorgen und diese dann versuchen, wer weiss wo da noch ne zeichen falsch steht?

Die Scripts 'funzen' hier einwandfrei. Um etwas zu unternehmen muss ich also zuerst nachvollziehen können wo bei dir der Fehler liegt.

Du beschreibst den Inhalt der _del_m3u-nfo-sfv.bat.mte, ich möchte aber wissen was in der _del_m3u-nfo-sfv.bat steht, die nach dem Ausführen der _del_m3u-nfo-sfv.bat.mta in deinem Albumordner liegen muss.

Und wie du diese .bat ausführst wollte ich wissen.
Hast du den entsprechenden Tooleintrag angelegt?

also in der bat die ins Verszeichnis geschrieben wird steht:

@echo off & setlocal
del *.m3u
del *.nfo
del *.sfv
del *.pls
del *.wpl
del _del_m3u-nfo-sfv.bat

goto:eof

_del_m3u-nfo-sfv.bat
in der Steht: Export"_del_m3u-nfo-sfv.bat"
wenn ich dann auf bearbeiten klicke geht das Exportfenster auf
Exportdatei auswählen
_del_m3u-nfo-sfv.bat
Dateiname der Exportdatei
_del_m3u-nfo-sfv.bat

Häkchen bei: Eine datei pro Verzeichnis

unter Tools ist auch etwas angelegt
Name: del m3u,nfo,sfv
Pfad: C:\Windows\System32\cmd.exe
Parameter: /C _del_m3u-nfo-sfv.bat

So wenn ich die Aktion ausführe wird nichts gelöscht aber es wird eine bat angelegt im Verzeichnis

Wenn ich unter Tools die: del m3u,nfo,sfv starte gehen etliche dos fenster auf und danach sind die dateien gelöscht.

wenn ich die bat direkt im Verzeichnis ausführe sind danach auch alle gewünschten Sachen gelöscht.

Ich dachte das geht mit einem klick automatisch?

Nein, eine .bat per action starten geht meines Wissens nicht.

und wie mache ich das jetzt?
warum gibt es solche scripts wenn sie nicht funzzen, oder bitte erklärt mir jemand wie ich sie benutzen muss.

Funktioniert doch. Und genau so ist es auch gedacht.

hallo an alle mp3tager und scriptprofis
hallo newser

seit tagen bin ich am verzweifeln beim erstellen einer nfo. ich habe die scripts runtergeladen und wie vorgegeben gespeichert. meine nfo hat beim artist immer "missing category" und es ist nie eine trackliste dabei. ich habe so eine nfo als txt angehängt. bitte um hilfe, wenn jemand zeit dazu hat

cu

synadari

67_1.nfo.txt (9.45 KB)

Dann fehlt im COMMANDS-Tag die Angabe der Kategorie, in dem Fall wäre das "sampler," (ohne Anführungszeichen, mit Komma)

hi und danke für die antwort

ich verwende deine nfo.mte und da fragst du doch selbst ab, was es ist - oder lese ich dein script falsch

auserdem war das nur ein beispiel für alle ausgaben des exports - egal ob sampler oder album etc.

vllt. gibts doch noch ne hilfe?

danke schon mal

cu

synadari