Tagging compilations

Help, Pleeeease help.

I’m using LMS plus the Squeezebox control app.
My music folder structure is: Music > Artist Name > Album date/name > Flac files + Jpeg of cover

This makes me happy:
I search by… My Music > Artists
When I do this I get a list of all the Albums by that Artist in chronological order.

This makes me Sad:
I sometimes see compilation albums under an Artist, because the album has a track by said artist.

The complication:
If I already have the track from the compilation on one of the Artist’s albums I don’t want to see it.
If I don’t have the track from the compilation on one of the Artist’s albums I do want to see it.

The fix:
I’ve created a folder under the artist called “artist name Misc” and pasted duplicates of tracks I do want to see in to that folder.
Using MP3Tag, I’ve deleted all metadata from these tracks apart from Artist and Track and added to a dummy Album called “[Artist Name] Misc”. I’ve even selected a nice image of the artist and added it as the cover of "[Artist Name] Misc".
Alternatively, if I happen to have a greatest hits album, I simply add the track(s) to that album and call them “Bonus” tracks and give them the same metadata as the greatest hits etc album has.
Meanwhile, I’ve left the track(s) also with the compilation album but removed all tags that reference (or may have some hidden reference) to the Artist.

The problem… oh the darn problem….:
Firstly its worth saying the above “fix” has worked for ~ 80% of the Artist/Tracks I’ve applied it to, but why oh why not all?

Here are examples of failure:
Under Duran Duran I see “Greatest” hits album (Good) but also “The best of James Bond” (no go away)
Under ELO, I see their greatest hits which include bonus tracks of my own adding (Great) but also those same "Bonus" tracks listed separately outside of the album (Whaaat?!).
ZZ Top albums appear as they should but also the Armageddon Album which I’ve deleted ZZ Top metadata from.
Goldfrapp, Moby and Radiohead searches yield the artists Albums (Yes) and my dummy “Artist Misc” albums (gooood so that works) but also the darn Soundtrack/Compilation Albums I’ve supposedly deleted all artist metadata from (leave me alone).

So you get the idea.

The effect on my sanity:
Argggghhhh…….!!!!!

So please very clever people - what have I missed?
Thanks
Alex

Could you find out why the player still shows data that should not be there?
Is there some kind of cache, database?
What happens if you rename the files so that the player has to find them again?
And if all fails:
supply a screendump of the extended tags dialogue (Alt-T) of a file that works and one that does not.

In general: removing data is sometimes not the best idea as even the criterion "data not present" leads to grouping files. The best way would be to have the same fields filled for all files - even if the data is some kind of dummy data. But that is usually better than no data at all.

To me it looks like the problem is the missing tagfield ALBUMARTIST.
That tagfield should care for the albums, where you have several artists, i.e. sountrack-albums.
In these cases the albumartist-tagfield could be "Various Artists".

Thanks for the ideas. The comments about extended and missing tags prompted me to poke around in the App. I looked at the misbehaving tracks and found you could see ALL tags. I was presented more than I could se in Mp3Tag even using the extended tags feature.
Although I had deleted 'Artist' from the compilation album, guess what?... 'Track Artist' was still there and hidden in Mp3Tag - that's now deleted.
And on the individual tracks (copied from compilations and pasted to the Artist's NAS folder) I thought I had deleted the 'Album title' but guess what? MP3tag hadn't shown me 'TALB' which also referenced the Album Title.

I'm now running a clean wipe and scan. Is there anyway to make MP3Tag truly expose all tags?

Thanks

This is the id3 name of the field that is shown in MP3tag (normally) as ALBUM.
See the help on field mappings:
https://help.mp3tag.de/main_tags.html
Then I would run a consistency check over all the files (no, it does not matter that they play allright), see this thread for some useful programs:


I recommend MP3val and MP3diags.
Once you get no other errors in MP3diags than complaints about low quality audio, padding and missing replaygain data, try the files again.
If you do not see something but it should be there, check also the settings in MP3tag at Tools>Options>Tags>Mpeg which tag versions you read, write and delete.
A good idea could be to get rid of APE tags.

Thanks - I'll give them a try.