Unable to open MP3Tag

Since yesterday, I've not been able to open MP3Tag - either on 3.08 or 3.08d (the latest dev build). The error log is empty, and I don't see any explicit error in the normal log as well.
After trying to open MP3Tag from the explorer context menu or through the start menu - nothing happens. A process is spawned with the name of Mp3tag.exe in the task manager too, but the memory used by it varies, so my assumption is it's running somewhere.
Any help would be much appreciated, especially as it was working fine till a day before. My Windows 10 version is the 21-09 update of Windows 10 20H2, 19042.1202.

EDIT - It opened, but around ~30 mins later, and then when I closed it and tried to open again it's still stuck in the task manager. I have no idea what's happening in the background.

here is a similar report:

as that did not generate any further helpful feedback from the OP's side, perhaps you can either try the suggested remedies or shed some more light on the circumstances.

Restart windows - not shutdown and start again but restart.

I don't know what fixed this, but some things that I tried that might have fixed the issue -

  • Installing yet another update that popped up for Windows 10 - KB5005565
  • Restarting my PC
  • Deleting the MP3Tag folder for v3.08 (using Lockhunter), and installing v3.08d

Another thing I noted was that the folder I failed to open was around ~400 MB, and it had 28 files, not all of them FLAC files - it had cue/m3u/sfv/log files as well. So this also might be a performance-related issue. I keep my Windows Defender manually disabled, and I don't use any antivirus (I just run a bimonthly scan using Malwarebytes) so I'm pretty sure an anti-virus slowing MP3Tag down is not an issue.
But in any case, I think this thread can be closed. Thanks for the help @poster and @ohrenkino!

It would be interesting to see whether opening these files caused the problems.

The problem goes away upon reboot and then spontaneously reappears after enough system uptime has passed. I'll try to get back to you when it happens again.

Could you also check with Process Explorer what the Mp3tag.exe process or the system in general is doing when it's not opening?