Windows 2000 no longer supported?


#1

Hello,

the Changelog for version 2.39h includes:

CHG: supported operating systems: Windows XP, Windows 2003, Windows Vista, Windows 2008

Does this mean that mp3tag is just not going to be tested unter Win2k anymore or did you add any functions that do not run under that OS, Florian?

My Windows 2000 installation is doing fine and I have no plans to update to later Windows versions. If I ever have to change, the next OS will propably be Mac OS X or Ubuntu.

Regards,
Martin


Win2000 unsupported?!
Wird Mp3tag v.2.41 noch für win 2000 kommen?
#2

Yes, I won't support Windows 2000 anymore.

I simply don't want to

  • spend my free time on testing Mp3tag on Windows 2000
  • spend my free time on inventing and coding complicated workarounds for Windows XP features that are not available on Windows 2000
  • spend my free time on coding special workarounds for Windows 2000 specific bugs

If your Windows 2000 installation is doing fine, your Mp3tag v2.39 installation will also do so.

Kind regards,
Florian


Wird Mp3tag v.2.41 noch für win 2000 kommen?
#3

Thanks for the quick response. I understand your position.

Could you just let me know if the v2.39h already contains XP-specific functions that will not work on Win2k?

Regards,
Martin


#4

Yes, it does.


#5

:frowning:


#6

Is there a way to download the latest W2K compatible build (2.39f) ?
I've tried to 'hijack' beta download URL (m -> f) But it didn't work, unfortunately.


#7

I agree.

Please make the last stable and the last beta version for Win 2k available for download as well. Like the separate DL for Win 98. But please offer both versions (the last beta and the last stable, if that makes sense).


#8

I too wish there were a copy of the last supported development build available somewhere on this site.


#9

Yes, that would be helpful.


#10

Florian, can you please put the latest development version that worked with Win2k on the website?

I liked how the plus sign at the bottom right of dialogs allowed you to select additional %variables%, but I reformatted and lost it, and the stable version doesn't have that feature.


#11

Florian, I love the program, heck, I even sent you a book from your Amazon.de wish list. Mp3tag was one of the last things tying me to Windows, but now I run it in Wine in Linux and every time I start 2.39 up it suggests that I check for a new version, but unfortunately, 2.40 seems to be Windows XP & up only and I set up Wine to emulate Windows 2000.

It there some way to disable the upgrade message or install the updated version in Windows 2000 or its facsimile?


#12

As soon as you choose Yes, Mp3tag won't ask again. It only opens the download web site in your default web browser, so you're not forced to update.


#13

Why don't you just set up Wine to emulate Windows XP or Vista? You can choose it in winecfg, even different settings for different programs are possible.


#14

Great suggestion, nickless, it worked like a charm, and 2.40 seems fine so far on sidux (Debian Sid-based).

Florian, thanks for moving my post to the correct forum and the suggestion about the upgrade warning, I'll do that in Windows, now. I'm in the situation where I have to boot Linux to use a Windows program, or at least the latest version thereof (my desktop Windows rig is 2K).


#15

Hi there

Is there a real reason for the removed support for Win2k?
I could start it easily by extracting the NSIS installer manually and removing the DLL entries for freeaddrinfo and getaddrinfo from WS2_32.dll and SHCreateShellItem and SHParseDisplayName from SHELL32.dll. Basic functions run fine, internet features don't work anymore (guess they now depend on these new found 'XP only features').

If you really depend so much on these new functions you maybe could make the internet features an option and still allow Win2k users to run the program. Would be nice.

Also it's a bit stupid to ask a user to upgrade to a new version that doesn't work on his computer anyway...

Thank you and greetings from Switzerland,
Bernhard


#16

Yes. Please see the second post in this topic for an explanation.

My capabilities in predicting the future are still limited. But I'm working on it.


#17

It's sad, that Windows NT 5.0 isn't supported any more. Version 2.38c supported WinNT4.0 an now 2.40 requieres XP, very hard.


#18

I agree, very sad...


#19

But, back to the question at hand, I would like to update from 2.38 to the last 2.39 version that will still run on Win2000. Is that available and where can I get it. I will not be "upgrading" to any of the newer Windows platforms. I guess my only other alternative is to run 2.40 in Wine on my Kubuntu system.


#20

I've added Mp3tag v2.39 to the download site under "old versions".