[WS] Discogs (pone mod)


#821

Jokertest,
I'm sorry to report that I get the same message when I search with label and catalog using cbs&catno=CK 38243. Previously I tried Search by Album(Artist) + Title and that also gave the same message.

Today I tried the Tag Source discogs that I believe is a default with Mp3tag. When I click on Tag Sources, it is the entry below Cover Art. It has the album title, I click Next, and have a list of albums. I select the one with the correct year, 1983, format, CD, and company, CBS. There are two in the list, and the second one is for release ID 721701. I click next and the script is able to retrieve information from discogs for release ID 721701. Maybe this script works because it doesn't retrieve as much information from discogs as the pone scripts do. I'll probably use this script and manually add/modify tag information for this album.

Thanks for looking into it.

Gary


#822

Help with discogs Pone oauth failure. I'm using 2.80c of MP3tag.

I've just installed this for the first time today having previously used the standard discogs function. I've done the install into the %appdata\mp3tag\ directory, run both of the action steps, update settings and create scripts.

The first Oauth failure I logged into my discogs account and removed mp3tag. Went through re-authorizing mp3tag and the standr discogs works but I get an oauth 403 failure with either the extended scripts or the discogs Pone scripts.

I'm sure its my mistake, but I'm at a loss. Help?


#823

If I'm understanding your post correctly, I think I'm getting a similar error. The error I receive is "Error connecting to server: www.discogs.com >> 401 unauthorized". I'm a very new user of MP3Tag and discogs, but near as I can tell, I followed all of the steps in the top post exactly. :unsure:


#824

No, this is not the same problem. I'm getting 403 authorization errors using additional scripts with discogs from mp3tag. The base discogs tagging function found under tag sources works fine.

In order to use the built-in support, when you first use it, you will be directed to discogs to log-in with your discogs ID/Password and copy an API key to mp3tag. If you've done that and are using the base discogs function in mp3tag, then I'm not sure how to help. I'm just a user though, not an expert.


#825

Anyone? I have not been able to get the authorization to work, yet it works fine withy the built-in discogs function. I'm sure I'm doing something wrong but would appreciate a pointer...


#826

same problem here buddy, using the latest version. im quite certain there is no error on my part. it is either a problem with the script or discogs.


#827

Can I run these scripts as a batch, rather than one song at a time? Billiant work, can finally get Genre.


#828

@MarkC I've been using the Discogs Pone> Direct by Discogs ID script for the past three weeks without any problems. Are you sure you are using the latest versions of the scripts? The last time we had 403 errors the changes to fix the problem were outlined on page 53 of this thread around reply #781.
Hopefully that will help you.

Gary


#829

Hi,

mp3tag - v2.80
pone - 4.4 Update 1

Everything works fine, except for certain search criteria which results in a 401: UNAUATHORIZED.

I have followed all previous steps with regards to [OAuth] etc.

For example, perform a standard search for the following.
P.O.S. Gravity (Original Mix) = 401
P.O.S. Gravity = 401
P.O.S. = 401
POS = No 401, but not finding relavent results.

The discogs ID that I am trying to get a result for is : 363202

Essentialy, whenever there is a period (.) (hex code 2e) in the search query, my search will fail. Maybe this is an issue some others are reporting with 401's, not realising the period in the search query is giving them this error.

PS. Awsome script.

PPS. Would be cool if there was an option to specify the Genre seperator in the .mp3 settings file - ie pone gives 'House\\Trance\\Techno' - i Prefer 'House / Trance / Techno'

I did manually do this for anyone interested, with the following code change (but would be nice as a settings option)

#< ## GENRE # 
outputto "GENRE"
findinline "\"genres\":" 1 1	
sayregexp "(?<=\")[^,].+?(?=\")" " \\\\u002f " "],"
gotochar 1#>

#830

JmmyBoy
I'm using Mp3tag V2.80 with pone 4.4(joker01 update). When I use Direct by Discogs ID with Discogs ID 363202, I don't get any errors and get the Discogs information. I don't know if you've only tried the standard search or if you have tried other searches. When I know the Discogs release ID, I always use the Direct by Discogs ID search.

Gary


Hilfe zum Erstellen einer veränderten Discogs Tag Source
#831

I noticed that most of the composer/written by tags don't load to the tag filed "composer" although I set it to do it as extra fields. For some reason one to three show up, the rest looks like it hasn't been pulled from discogs. Any suggestions?


#832

Hi Gary,

Searching by Discogs ID works fine for me, I was just giving that as a reference to the release I was referring to.

The point I was trying to make is a discogs Standard Search with "P.O.S. Gravity" will result in a 401, searching for "POS Gravity" will not result in a 401, but does not display any relavent results. Essentially, I find that when the search string contains a period (.) the search will fail with a 401.

Thanks


#833

Any way to combine each set of the tracks below of disc two in this release?

See CD2: https://www.discogs.com/Stephan-Bodzin-vs-M...release/2760764

Such as combining:
a, b & c of 2.5
a & b of 2.7
a & b of 2.12

The tracks are:
2.5a Callisto
2.5b Callisto (Joris Voorn Remix)
2.5c Callisto (Dominik Eulberg Remix)

2.7a Phobos (Pan-Pot Remix)
2.7b Phobos (Synthapella)

2.12a The Alchemist
2.12b The Alchemist (Robag's Kopakkmuuf-Rekksmo)


#834

Hello everybody,

Does anyone have any Discogs script that does the search by artist name and music? I'm trying to adapt what I have here, but it's complicated and I'm running out of time.

Thanks all!


#835

In UPDATE (v2.7) a new tag field called CHAPTER was introduced.
The chapters or disc names found as headlines above or between the tracklist at discogs.
Look at this pages for examples:
http://www.discogs.com/Joy-Division--Singl...release/2586049
http://www.discogs.com/Kraftwerk-Der-Katalog/release/1996371
http://www.discogs.com/Erykah-Badu-Mamas-G.../release/424341
It works fine but I don't understand how to make use of it or which software makes use of it.
I can't get it to work in Logitech Media Server / Slimserver?
Is there a way?

Kind Regards
Johan


#836

Hi Johan,
here some basic information about chapter mark:
http://id3v2-chap-tool.sourceforge.net/
https://auphonic.com/blog/2013/07/03/chapte...anced-podcasts/
https://auphonic.com/blog/2013/07/03/chapte...anced-podcasts/

most player out there can not handle chapter. you need a player where you can add custom library field and maybe it work.
for me I use JRiver https://www.jriver.com/
and I add this field in my library. check out the uploaded pic.

JRiver is not for free but for me the best player out there coz I have a hug collection and no other player can handle my few mp3 :wink: . this player have some more cool features

regards jokertest



#837

For the love of god, can anyone help me out? I'm trying to assign the track number in multidisc releases to the track field, and disc number to the discnumber field, easy as that.
I only get combinations of track+discnumber in the TRACK tag, e.g. track 1.1

I would like track 1.1 to have 01 as TRACK and 1 as disc number.

I'm guessing it has something to do with the track positions as mentioned on Discogs.
Is there any way I can tell the script that track position 1.1 (or 1-1 for that matter) means "discnumber.track" (or discnumber-track)?

UPDATE: just found out!
I had to remove "TRACK" in the line below.

Trackposition (as written on discogs page): >TRACK

  • write Trackposition only for Vinyl & Cassettes >no

#838

+1 on this!


#839

401 :frowning:

http://prnt.sc/eubrgu


#840

Search?
/t/17761/1
[WS] Discogs (pone mod)