[X] Action groups button works to quick



I would like to complaint about the action groups button. The problem is this:

if I click at very right edge of it, then a single click is counted as two clicks and an action gets executed; while all I want to do, is to see the list of my per-defined actions

This annoying issue comes to be with very long list of actions, when they have to be displayed not and not below it, but also at the and above the level of the action groups icon

This issue "disappears" if on such a long list, an action is not really an action [than can be executed] but an entry for a sub-list of actions [grouped by name]

REQUEST: move list of actions right next to its icon

Are we talking about this button :mt_act: ?
If you click on it, you execute that action that you have ticked in the dialogue Actions>Actions.
If you click on the dropdown-arrow next to it, you open a menu. By definition, entries in menus do not need a double-click but react to a single click ... so I do not see an illegal reaction.


After some trials I was able get the same effect.
At first press the button for the dialog "Actiongroups".
Then close the dialog.
Then press the triangle button to open the menu list of predefined actiongoups.
If you do this process fast enough, then Mp3tag executes some action group and displays the action's result dialog.
This behaviour is not good.




The problem is with the triangle sub-icon; that with one click is suppose to only show the list [and not execute an action from a long list of actions, that happens to be "under" it]


What I can get:
Normal click on down-arrow of a long list opens list.
I can now move up and down that list without any function being triggered.

Instead of normal click on down-arrow of a long list i keep the mous button pressed: list opens.
And even though there is an action name under the mouse cursor, this entry does not get selected until I release the mouse button and click again.

As this behaviour is managed by Windows, you should get the same behaviour in other applications.

So: have you checked the control panel for the mouse and e.g. the settings for the double click frequency?
Have you recently changed your mouse?
Do you run 2 mouse drivers at the same time?
Have you got a mouse with a mouse wheel serving also as middle mouse button? Could it be that the driver has a hickup and you have to click that mouse wheel once to reset it?
Do you have a left mouse button that has a loose contact?
This is where I would look.


No, no, no; that's not the case

The problem is only in Mp3tag; although my previous description was wrong

The action gets executed if you click the triangle [not necesarilly on it's right side] and at [the same time?] move the mouse pointer. so please try this: start to slightly move the pointer [carefully, so you won't move it out of the icon area] and then click to see the list - and you'll see the list for a brief moment and will get an execution of action [the click has to be qucik- don't hold it for a later release]


What I can get:
Click once on the mentioned icon: Dialogue "Actions" opens.
Press the mouse button while the cursor is on the icon: icon shows that is has the focus
Option a: release the mouse button: Dialogue "Actions" opens.
Option b: move the cursor to the arrow and release it: Dialogue "Actions" opens.
Option c: move the cursor to a different icon or some other area: nothing happens, icon changes back to "not selected" look.

Click on the arrow: List opens, moving around with the mouse cursor will move the selection bar from menu item to menu item, if cursor leaves menu area, nothing is selected, menu stays open until a click either hits a menu item or some other area. If a menu item had the focus, then this action is carried out.

Double click on arrow: action that happens to be under the cursor position is executed. If there is no action under the cursor, a double click causes a flickering of the menu as it is opened twice but no action is executed.

A single click - and that property is set by windows - opens only the menu, no action is executed.


Here is the movie showing the existence of the bug


At first time I do it slowly [and thus need two clicks to excute an action]

At second time I click and move at the same time [having action executed without consent]


I still doubt that this is a bug - the video shows a behaviour.
But I tried my best and clicked and pressed and dragged and I cannot reproduce the behaviour. I tried it on pcs with WXP, W7 and W8.1 and none behaves like an unvolountary double-click.

I know that sometimes Windows does a strange kind of refresh of the screen so that e.g. a newly created menu is redrawn so that an element of that newly drawn object gets the focus again which then behaves like a click.
This is often a problem of the local constellation of hardware, open applications and drivers.


The only solution for me right now is to keep an sub-menu action groups at the top, so that I don't accidentally execute something


I've just made a request of moving the list a little more to the right, which would avert this problem from occurring on a daily basis



I can rule out the hardware as a culprit

Two new mice later the problem is still present