[X] Discogs authorization doesn't work

Hey Florian and other users,

first up I'm a huge fan of mp3tag and have been using it for a long time. Thanks for providing such a great tool! Especially the import function from Discogs is super useful.

Sadly, a few days ago the Discogs source stopped working. I was using v2.82 on Windows 10:

  • I clicked on the Discogs Button
  • then I could enter a search term
  • then I received the message Failed to authenticate using OAuth (1). >> 401: UNAUTHORIZED

So I installed the newest Version of mp3tag (v2.83) but it still didn't work and I kept getting the same error message. The current Beta-Version (v2.83c) didn't work either.

On Google I found this forum and tried out some of the solutions suggested here:

  • checking if my firewall allows mp3tag to connect to Discogs
  • changing parameters in the discogs.src file
  • revoking mp3tag's access in my Discogs account

But none of them helped. The only thing that changed ist that I can't even enter a search term anymore, I get the error message straight after clicking one of the Discogs Buttons.

What seems really strange to me, is that the Discogs authorization window doesn't pop up automatically in my browser, as I expected it to after revoking the access. Is there a way to trigger the authorization manually from mp3 tag? Or is there another way to solve this?

Thanks for your help and have a nice weekend


Hey Simon,

can you please try the following:

  1. Reinstall Mp3tag v2.83c (just to make sure that you have the latest Discogs tag sources without any local changes)
  2. Login to your Discogs account and revoke access to Mp3tag from https://www.discogs.com/settings/applications
  3. Use the tag source labelled "Discogs" from within Mp3tag
  4. Authorize Mp3tag when the Discogs authorization page appears
  5. Paste the authorization code into Mp3tag
  6. Done :slight_smile:
Kind regards – Florian

Hey Florian,

thank you so much for your super quick reply!

I followed your steps:

  1. Downloaded and installed v2.83c

  2. mp3tag's access was already revoked so there was nothing on the application page in my Discogs account.

  3. The error message Failed to authenticate using OAuth (1). >> 401: UNAUTHORIZED appears immediately when I click on the Discogs Button.

  4. The authorization page doesn't appear. It goes straight to the error message above.

What could this be?

Hey Simon,

if the authorization page doesn't appear, requesting the initial authorization URL fails. Can you check again any firewall settings (also the ones on your router if any).

Kind regards
– Florian

Still no luck unfortunately :confused:

Just checked the Windows firewall: mp3tag is allowed to communicate in all types of networks.

Searching for releases in MusicBrainz works fine.

Is there a way to manually enter the Discogs authorization URL into my browser?

Hey Simon,

unfortunately, pasting the auth url in the browser is not possible. Mp3tag also stores additional information in its settings, which is then needed for working communication.

Can you try something unconventional? What happens if you temporarily rename the Mp3tag configuration file at
to, e.g., _mp3tag.cfg and try the process with a fresh configuration?

Kind regards
– Florian

Hey Florian,

I renamed the configuration file and when I restarted mp3tag it successfully created a new mp3tag.cfg in the same folder. Other than that nothing seems to have changed, the error keeps popping up everytime I click the Discogs button.

Is there anything else I can try?

Hey Florian,

good news!!! Today, all of sudden, the Discogs authorization worked just fine! The tab automatically opened in my browser, I authorized mp3tag in my account and now it works again :slight_smile:

I'm not sure why this happened, because I didn't change anything about my laptop or my internet connection. If I find a reason or a pattern, I will let you know!

Thanks again for your dedication and your support!


Hey Simon,

that's really good news – glad that it's working for your now! :slight_smile:

Kind regards
– Florian

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.