[X] The True Audio: ID3v2 Tags Mistery


#1

So, here's the case:
I've tried to write ID3v2 tags to some *.tta files. The process of writing was successfuly accomplished and inside Mp3Tag i could see all the tags, including the long ones, which couldn't be ID3v1. The process was pretty long, including the full rewrites of files to the disk. So, i suppose the v2 tags were actually written.

BUT, i cannot see these tags anywere but in Mp3Tag. Winamp w/TTA plugin can't see them (only v1 tags are shown and, surely, they are truncated). dBpowerAmp shell extension also can not show them. Note, that TTA plugin for winamp isn't that old and it does support v2 tags.

Then i open Mp3Tag again - and here they are, my v2 tags!

"Au contraire", when i write v1+v2 tags into TTA files using winamp, Mp3Tag cannot see the v1 tag.

p.s. i don't use any other player, but winamp, so anywhere in this post actually means winamp and dbpoweramp convertor shell extension.

Added: i also tried to turn on "write only v2 tags", but it does not change anything (


no support for ID3v2 tags in Tau True Audio?
#2

Can you please enable the option Always write ISO-8859-1 tags instead of UTF-16 at Options > Tags > Mpeg and re-save the tags?

This should solve the problem (explained here).

Best regards,
~ Florian

Btw: nice to see someone that uses TTA with Mp3tag :slight_smile:


#3

Yep, that helped! I can see now tags written by Mp3tag in winamp, though it shows only v1 in playlist it does show v2 in file info. Thanks! Good luck! )

P.S. Actually, i started using Mp3tag because it is the only tagger that acceptably supports TTA file format. Before that i used Mp3-Tag Studio 3, which is also quite powerfull, but only supports mp3 format.