Can't Start MP3Tag With Multiple Files Selected

Beginning with this latest release, MP3Tag will not start if I select multiple MP3 files, then right click and select the program. It will work if I select only one file, and I can also go to Directory and reselect the path to bring up the rest of the files in a directory.

(which one)
I am running 2.95b at the moment.
I don't know if this is really a new behaviour but I could think of a reason why it is like that:
You cannot run more than one instance of MP3tag. So if the shell opens the first file, you have your running instance. when it then tries to open the next file, then this gets refused as there is already a running instance.
So your observation that you can either load a single file or a whole directory is correct, I think. You can see those options in the command line parameters that MP3tag allows:
The alternative would be to drag&drop the subset of files (or folders) into MP3tag.

I have 2.95. I don't see a b in the downloads section.

This is a new behavior, since I know I was able to run the software the way I described before. If it isn't a bug then I can run it the ways you mentioned.


See the development build status for the latest version:

and as that pages shows
FIX: runtime error when clicking on existing files while adding files via drag and drop.
I was wondering if that might have been the reason. But as you say that you use 2.95 it is none of the recent changes.

You can also add further files by holding down the Ctrl-key while dragging & dropping.

I've just tried to reproduce this and it's working as expected here. Given you've installed the Explorer Shell extension (and not some random registry hack) you should be able to select multiple files in Explorer, right click and select Mp3tag to open the selected files in Mp3tag.

Can you give some more details regarding the Windows version you're using?

@ohrenkino, it's a real shell extension which creates a M3U8 file for the selected files and passes this to Mp3tag via command line.

I'm using Windows 10 x64 with the current update. It was doing the same thing under the previous one. I have a screen capture video to show you how the software is behaving but it's too big even when zipped (10 MG).

Did you install it normally or did you select the portable version for installing?

I used the normal installation. I also tried completely uninstalling it and reinstalling it. Same problem. Since nobody else is reporting this problem I'm wondering if something else is interfering. The only software that also uses the context menu I've added recently is MysticThumbs. Not sure why that would cause any problems.