Dateiname --> Tag ohne Ergebnis

Hallo,
irgendwie ist es mir geglückt bei einem einzelnen Ordner mit 23 Songs einen Fehler einzubasteln.
(un)Wahrscheinliche Ursache: Spielereien mit dem Filter
Titel / Interpret / Album / Jahr / Track werden nicht mehr angezeigt.

Bisherige rep-Versuche:

1.) mittels dem Konverter "Dateiname -> Tag" habe ich versucht alles wiederherzustellen, aber es wird in den o.g. Feldern nichts angezeigt.
2.) Zugrücklesen aus einer Sicherung des Ordners bringt keine Besserung, es wird in den Feldern nichts angezeigt.
3.) die Ursprungskonfiguration zurück lesen: erfolglos.

Schritt 4 wäre jetzt, das Prg. zu entfernen, die Registry reinigen und neu installieren.
Das möchte ich eigentlich vermeiden.

Ist mir zu (noch) zu helfen?
Adventliche Grüße
Bernd

Wenn ich Dich richtig verstehe, geht es ausschliesslich um diese 23 Songs.
Alle anderen Songs werden richtig/wie gewünscht dargestellt?

Den Filter kannst Du mit F3 ein- und ausschalten. Damit siehst Du sofort, ob er wirkt oder nicht.

Kannst Du uns bitte einen Printscreen von Mp3tag mit einem dieser 23 Songs anzeigen, so dass wir sehen, in welcher Ordnerstruktur er liegt?

wow, das ging fix :slight_smile:

und JA, alles andere wird korrekt angezeigt

Probiere es bitte mit den Konverter Dateiname - Tag (ALT + 2) und folgendem Formatstring:
%album%\%dummy%\%track% %artist% - %title%
(in der Annahme, dass Du den Pfad-Teil \100_Old_098 nicht mehr benötigst).

Die Vorschau (zwischen dem Formatstring und dem Button "Vorschau") sollte Dir schon vor dem OK-Button drücken anzeigen, ob die richtigen - fett geschriebenen - Tags wie gewünscht abgefüllt werden.

Kannst du mal ganz nach rechts in der Dateiliste blättern und gucken, ob du APE-tags in den Dateien hast?
Und wenn das der Fall ist (oder vielleicht sowieso - in Extras>Optionen>Tags>Mpeg das Lesen von APE Tags ausschalten und die Dateien noch mal einlesen?

hier der angewandte string
teil1

Dann ist @ohrenkino auf der richtige(re)n Spur.

Ich muss leider gleich weg, aber wenn Du das mit den APE prüfst, kommt das auch ohne Neuinstallation oder Registry-Gefummel wieder in Ordnung. :+1:

ich hatte vorher alles auf IDv2 umgestellt, eventuell ist da NUR bei diesem Ordner ein fehler aufgetreten

danke für Heute schönen abend noch

1 Like

Das ist auch die bessere Lösung.
Nur: wenn du in den APE-Tags nicht(s viel) drin stehen hast, dann bleibt die Anzeige leer.
Wenn möglich, ließ und schreibe keine APE-Tags. Löschen ist OK.

Teil3

alle Sogs Kopiert und eingefügt
keine Besserung

wenn das die aktuelle EInstellung ist, dann sehe ich noch bei APE:Lesen den Haken. Der muss weg.

BINGO

Herzlichen dank, alles ist wieder da

Umd das Mirakel vielleicht etwas aufzulösen: MP3tag zeigt immer die APE-Tags, wenn sie da sind.
Da du jetzt ja weißt, dass keine Daten verloren gegangen sind, kannst du ja noch mal interessehalber gucken, welche APE-Daten denn da waren.
Dazu mach den Haken wieder bei APE:Lesen, lies die Dateien ein und dann öffne für 1 Datei den Dialog "Erweiterte Tags".
Ich vermute, dass du Mp3gain-Daten irgendwann mal hast ermitteln lassen.
Es gibt gute Programme, die diese Daten nicht in APE-Tags schreiben, sondern in ID3V2. Und dann hat man alles beisammen aber keine Verwirrung mehr.

Hier ist eine ANleitung, wie du APE-Tags wieder loswirst:

ich habe APE zu lesen gesetzt.
dann einen völlig anderen Ordner gewählt.
Das Ergebnis, es ist kein APE drin
teil4

(ich spiele schon viele Jahre mit dem Prg, jetzt versuch ich mich erneut an einer Sortierung. dabei kann damals auch einiges schief gelaufen sein )

auch ohne die Daten in APE-Tags zu lesen, könntest du mit dem Filter
%_tag% HAS APE
alle Dateien mit APE-Tags anzeigen lassen

mit dem Filter wird nichts angezeigt

moment .. ich hab mal 4000 daten eingelesen

der Filter zeigt nur die geladenen Dateien die mit APE an.
Vielleicht haben die aktuelle geladenen wirklich keine APE Tags.