[F] cue files are not read when they don't start with TRACK 01 AUDIO

I just tried to edit the cue files of a double cd which i have in mp3+cue format.
The first cue file was written in the standard mode, starting with TRACK 01 AUDIO, but the second (for the mp3 file of CD2) started with TRACK 15 AUDIO.
The Foobar player was able to read this without problem, but Mp3Tag could not. Only after manually renaming the tracks in the second cue file in notepad, Mp3Tag was able to read the file.

other problems with cue fiels:

You have to drag them separately into Mp3Tag. If you drag a folder into Mp3Tag, only audiofiles are read and cue files are omitted.
Maybe this is a wanted behaviour, but it would be nice if the user could deside somewhere in the options if cue files are read or not when reading complete folders.

The album artist is written as "Performer" at the begin of cue files. This is mapped to "ALBUM ARTIST" in Mp3Tag. I think it would be better mapped to "ALBUMARTIST" as this is the standard Tagname in Mp3Tag for this.
Question: Is it possible at the moment under Options > Tags > Mapping, to remap ALBUMARTIST to ALBUM ARTIST only for cue files? If yes, what tag type do I have to write there.

Another Problem with Cue Files:


If you write for examle "Ä - Ö - Ü" as Album Performer (ALBUMARTIST) and save it, it is displayed as "Ä - Ö - Ãœ" in Mp3tag, but written correct in the cue file.
The Problem starts if you save the cue file a second time with Mp3tag, then what was first only displayed is now actually written into the cue file. Furthermore, what is now displayed is "Ä - Ö - Ü".

When you do this a few times more, every saving makes new transformations to the text. It always writes the wrongly displayed umlaute as it is displayed and displays new longer umlaute.

so if you write "Ä - Ö - Ü", it goes like this:
Ä - Ö - Ü (first saving)
Ä - Ö - Ü (second saving)
Ä - Ö - Ü (third saving)
Ä - Ö - Ü (fourth saving)

and another little problem with cue files:

the (preinstalled, i think) tool for openening the containing folder does not work for cue files.

Tool: Explorer
Path: C:\Windows\explorer.exe
Parameter: /e, /select, "%_path%"

All problems still persist. Is there anything planned about it?

My question from above is still unanswered:
Is it possible at the moment under Options > Tags > Mapping, to remap ALBUMARTIST to ALBUM ARTIST only for cue files? If yes, what tag type do I have to write there.

Support for the SONGWRITER command/field in cue sheets would be another thing that I am missing.
Maybe mapped to MIXARTIST or COMPOSER. Best thing would be if mapping for cue files could be changed by the user.

Other fields which should be easy to support with MP3tag:

REM has the gereatest potential. It can be used to simmulate other tag-fields which are not natively built into cue sheets.
For example foobar supports REM COMMENT, REM DATE, REM GENRE and maps them to the corresponding standard tag fields when reading cue sheets. However, at writing cue sheets only REM DATE is supported from these three examples.

Here is a nice overview over the possiblilities of cue sheets: http://digitalx.org/cue-sheet/syntax/
I guess you know that anyway, Florian. It would be nice if the non-technical commands/fields would be fully supported.

After all this years, these bugs still remain. Why is nobody working on it? Especially that cue files only starting from track number 1 can be read is very annoying!

Please fix it.

Is it just me (I mean a problem on my side) or did this thread disappear and can only be found with the direct link?

€: After writing this post it appeared again. Strange.

Just a friendly reminder that problem is still existing.

In each forum you can set what's visible by using filters at the bottom of the page. Default is set to last 30 days, which makes older threads to disappear...

EDIT: It would be nice to have the setting default to "Show All" though...

I've addressed all of the issues described in this topic with the current Development Build Mp3tag v2.82d.

Thanks for your patience and thanks for reporting!

Kind regards
– Florian

Many thanks for this! I really appreciate it! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.