FLAC "Comment" metadata field doesn't appear in Windows 10

Hi all,

I am having trouble getting the "comment" field in my FLAC files to appear in the Windows 10 file explorer. I can see the text in Mp3tag, however, and if I edit other fields such as "Title" or "Album" those changes are reflected immediately in the file explorer. The "comments" column in the file explorer, on the other hand, stays blank no matter what I do in Mp3tag.

What I also noticed just now is that the field is labeled "Comment" in Mp3tag but it's "Comments" (with an "s" at the end) in the Windows file explorer. Could this be the source of the problem, and if so, is there any workaround?

I tried adding a custom field in Mp3tag called "Comments" but that didn't seem to work.

Any help would be most appreciated!

It could be that you have to adapt the variable
_M_STR_ID3V2LANG
to the language of your OS. Search the mp3tag lng file with your local language for that string.

Edit 2022: there is a function in the options to set the language in Tools>Options>Tags>Enhanced.
And as stated below: this only applies to MP3 tags.

Windows Explorer doesn't use the COMMENT field for the comments in FLAC, but instead uses DESCRIPTION.

If you'd like Mp3tag to instead transparently write the DESCRIPTION field when you enter something in COMMENT, you can add a dedicated mapping at Tools → Options → Tags → Mapping using

Tag: VorbisComment
Source: DESCRIPTION
Target: COMMENT

The ID3v2 language setting mentioned in the previous post (now at Tools → Options → Tags → Advanced) only applies to ID3v2 tags, used, e.g., with MP3 files.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.