Icon not showing in Taskbar when launched via context menu

Screenshot (19)
No Icon in the Taskbar on Windows 11

I think I've found a way to circumvent this and fixed it with Mp3tag v3.12a.

Hi,

I just installed Mp3tag v3.12a and unfortunately the icon is still not shown when starting mp3tag from explorer integration. I am running windows 11 home with all fixes installed.

Regards Manzi

You could try this workaround:

Sorry, but this didn't work for me either

When the program is started from the context menu, there is no icon on the taskbar. When launched from the shortcut, everything is ok.
Windows 11 Pro 22000.265, no tweaked
Mp3tag 3.14 d, e, f [x32, x64], standard installation

It should have been fixed with v3.13

[2022-02-10] FIX: taskbar icon was missing when starting from File Explorer shell extension under Windows 11 using Standard installation.

and the icon is showing for me in my test environment.

Maybe it's related to from where you're starting from the context menu? Is this on a local folder/files/network or any special location in File Explorer (search result or tree)?

No. When opening a file from the root of the C drive, there is no icon either.

Upd. Sorry. I ran from the context menu of Total Commander 10.50b4. From the explorer you can see the icon.

OK, thanks for adding this important detail.

The workaround I've implemented for Windows Explorer tries to execute Mp3tag using the Explorer instance. This prevents the Mp3tag.exe from being started with the identity of the DLL which results in no icon being shown on the taskbar.

The Mp3tag Shell Extension implements IObjectWithSite and queries the provided site for a series of COM interfaces to finally call IShellDispatch2::ShellExecute. It's quite a ride and it seems that this sequence of COM interfaces is not provided by Total Commander.

I'm marking this as #bug-fixed as it's now working for Windows File Explorer and TC's behavior is beyond my powers.

Thanks for the explanation!

Manually registering

regsvr32 Mp3tagShell.dll

helped me.
There was an item in the context menu and an image of an icon in the taskbar, including when starting from TC.

I've found a way to also make it work in 3rd-party file managers under Windows 11 without the need for manual registration.

From the changelog for Mp3tag v3.15:

[2022-05-23] FIX: taskbar icon was missing when starting via shell extension in 3rd-party file managers under Windows 11 using Standard installation.

Yes, after updating to 3.15, the context menu appeared in TC, but then disappeared. Haven't had time to analyze if it's related to the release of 3.16.
Apparently I am not the only one:
https://community.mp3tag.de/t/no-explorer-context-menu-integration/13891/26?u=imagine
Completely uninstalling 3.16 and a clean installation of 3.15 had no results.
While I am still in the research stage, will have any results, I will report.
Win11 22000.708

Name : 35795FlorianHeidenreich.Mp3tag.ShellExtension
Publisher : CN=Florian Heidenreich, O=Florian Heidenreich, S=Sachsen, C=DE
Architecture : X64
ResourceId :
Version : 3.15.0.0
PackageFullName : 35795FlorianHeidenreich.Mp3tag.ShellExtension_3.15.0.0_x64__hyhc94k68ebpm
InstallLocation : C:\Program Files\WindowsApps\35795FlorianHeidenreich.Mp3tag.ShellExtension_3.15.0.0_x64__hyhc94k68e
bpm
IsFramework : False
PackageFamilyName : 35795FlorianHeidenreich.Mp3tag.ShellExtension_hyhc94k68ebpm
PublisherId : hyhc94k68ebpm
IsResourcePackage : False
IsBundle : False
IsDevelopmentMode : False
NonRemovable : False
IsPartiallyStaged : False
SignatureKind : Developer
Status : Ok

Seems like you have installed the version from the Microsoft Store and the standalone version?

I always install only from here:

If I need older versions for comparison, which I don't have, here:

OK, and have you already tried restarting Windows Explorer via the context menu in Windows Task Manager?

I do this so often that I have a cmd-file on my desktop :smile::

taskkill /f /im explorer.exe
start explorer.exe
exit

OK, you're a pro :smiley:

Can you try this from an admin command prompt:

cd C:\Program Files\Mp3tag
powershell -c "Add-ProvisionedAppxPackage -Online -PackagePath Mp3tagShell.msix -SkipLicense"

C:\Program Files\Mp3tag>powershell -c "Add-ProvisionedAppxPackage -Online -PackagePath Mp3tagShell.msix -SkipLicense"
Path :
Online : True
RestartNeeded : False

Can the UAC settings be affected? I have them turned off completely.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
EnableLUA -> 0

I'll do some experiments later.

I've tried with UAC disabled on a fresh install of Windows 11 22000.708 and it works without problems.

If you're using an admin account you can also try from an admin command prompt:

cd C:\Program Files\Mp3tag
powershell -c "Get-AppxPackage -name *mp3tag* | Remove-AppxPackage"
powershell -c "Add-AppxPackage Mp3tagShell.msix"

I've also just learned about Get-AppxLastError and Get-AppxLog — maybe they can shed some light into this issue?