MP4 Cover Art problems Windows 11 22H2

Anyone else having problems adding cover art after installing Windows 11 22H2 update (and the accompanying cumulative update)? It was working perfectly until the update but now when I try to add cover art, mp3tag reacts very slowly and then locks up hard - I have to use task manager to get it to close. All other features of mp3tag seem to continue to work well.

Note that I am using the current mp3tagv318-x64 version of mp3tag

It's working fine here. How big are those files and are they on a local drive?

Quick update - I have 2 Lenovo 11A9 series desktop computers, and a Lenovo 20T8 series laptop. I run mp3tag on all of them. The problem occurs on both of the desktop computers, but it does not occur on the laptop. All 3 are running Windows 11 ver 22h2. One of the desktop computers contains my cover art file, which is also shared with the laptop and the other desktop computer. So it doesn't seem to matter whether the cover art file is local. Since it's obviously a weird error (and I have a workaround), I admit that it's not a high priority. We can wait and see if anyone else encounters it and try to identify a pattern.

Can you copy the pictures from the sharing desktop pc to the laptop?

Yes I could but the laptop is the one computer that isn't experiencing the problem. I could copy the the artwork from the server to the desktop client but I don't think that would help, since the artwork file is local to the server, and the errors occur when I run mp3tag on the server.

As you have a rather mixed up setup it would be worthwhile to narrow down the various influences.
So one would be: is the picture accessible at all? Yes, this would be the case if you can copy it from the shared folder to a local folder.
Can you add that picture locally? If that is so, this would probably mean that the file is OK and MP3tag is working OK. But it would also mean that something is matter with the network configuration.
This would have to be investigated by you locally as no-one has your setup anywhere.

To answer your specific questions -

Yes the cover art is accessible by means other than mp3tag. I can also add cover art with mp3tag on my laptop (over the network), even if I can't add the same art to the same MP4 file on the two desktop computers. And once added to an MP4 file, I can use mp3tag to copy and paste the same cover art from that MP4 file to another MP4 file on my desktop computers, even if I can't add it directly.

I cannot add cover art locally if I can't add it over the network. So it doesn't seem to be a network issue.

I'm pretty good at trouble-shooting but this one has me stumped. My post is intended to see if anyone else is having the issue - if so, then we can look for commonalities.

So, does that mean that the file is not OK?
have you checked it as recommended here:

For me, the bottom line is that it's one thing for some operation to not work, but it's something else altogether to have a particular operation (in this case, adding cover art to an MP4 file) cause mp3tag to lock up completely, without any error message, and require the use of task manger to terminate mp3tag so I can regain control of the computer. And it's also interesting that mp3tag was working flawlessly until I installed the Windows 11 version 22H2 update (and the associated cumulative update and previews). What could possibly cause mp3tag to do that?

I admire your tenacity and willingness to try to help, but I think you're missing the point that things were working perfectly well until 22H2.

Thank you for telling me that I am ignorant.
What I try to get is some kind of systematic information from you.
And that starts with the file. Usually, one checks the integrity, then the picture file.
if that is OK, then it goes on to the accessibility in your particular environment.
This could have to do with access rights (yes, I know you claim that nothing has changed but still ... why not make sure that these are really still the same).
If the ordinary access has been verified then it could be problems with other programs like virus checkers, indexing programs, e.g. like here:

I would even check if the computer time is the same on all you devices.
But for narrowing down the cause more information has to be supplied by you.

Good thought regarding the anti-virus software. I use Avira on all 3 computers and I checked to make sure that the update didn't set me back to Windows Defender, and it did not. While I was there I noticed that a second cumulative update to 22H2 was ready for restart on the server (different build number from the first one). I'll go back in a few minutes and see if there's any change with regard to mp3tag. And for the record, the issue I'm encountering isn't just a slow loading speed - it's a complete lockup of mp3tag, requiring termination via task manager to get moving again.
And as an aside, two cumulative updates of 22H2 in about as many days seems to me to indicate an unusually buggy version.

Quick update - I did install "2022-10 Cumulative Update for Windows 11 Version 22H2 for x64-based Systems (KB5018427)" on my desktop/server last night; mp3tag still locks up. I also installed that same update on my laptop, mp3tag still works fine. Perhaps worth noting (and perhaps worth nothing), my laptop has the following update installed but the desktops do not: "2022-09 Cumulative Update Preview for .NET Framework 3.5 and 4.8.1 for Windows 11, version 22H2 for x64 (KB5017271)". I don't know what an Update Preview does, nor do I know if mp3tag uses .net.

So, what happens if you install that missing package on one of the dektops?

It hasn't shown up in Windows Update on the desktops yet

Update: I decided to try putting cover art (JPGs) for the MP4's I'm working on in the same working folder/directory as the MP4s. That configuration works for mp3tag even on the computer that has the cover art folder locally (as opposed to shared via the LAN). From that I conclude that the issue has to do with access to the cover art folder. I checked the Properties for that folder and it's quite large - 4168 files (individual JPGs) and 498 MB (517 MB on disk). I'm not up to speed on access methods for PCs so I don't know whether the size or number are a potential problem, but at least I now have a better workaround.

This'll probably be my last update for a while. This quirk is just too crazy, and if nobody else is running into it I may just have to live with it.

First thing - the Windows update that was on my laptop but not on the desktops has now come down on the desktops as well. As you probably suspected, it hasn't made any difference. They still lock up if I try to add cover art to an MP4.

Second thing - I have an old Lenovo tower computer that's been running more-or-less 24x7 for the past 10 - 12 years. It doesn't meet the hardware requirements for Windows 11 so it'll be forever stuck on Windows 10. But it still runs as well as it ever did, so I decided to load mp3tag up on it to see what would happen with cover art. Mp3tag is configured the same way on the tower that it is on the laptop and the client desktop; i.e., cover art is accessed on the server but the working director is local. Oddly enough, it works like a champ.

The cover art folder is quite large - 4,168 files (individual JPGs) and 498 MB total (517 MB on disk). Individual JPGs average around 120 KB (yes I figured that on my calculator but verified it with a quick look-see). I access the cover art locally when I run mp3tag on my server, and I access cover art via the LAN (wireless) when I run mp3tag on my laptop or desktop client. The MP4 files I'm tagging are always local. I've noticed that when I add cover art to an MP4, it usually requires the entire file to be rewritten and that can take a long time if the MP4 files aren't local (because the files are usually pretty big, sometimes very big; some movies are 4 GB or more depending on resolution and compression). Cover art JPGs are trivial by comparison so it hasn't mattered whether they are local or networked. Text tags don't usually require the entire MP4 to be rewritten.

Maybe you've answered this before, but does the lock happen when you try to select the cover art file via the open file dialog or after you've selected the file and Mp3tag is saving the MP4 file?