No Explorer context menu on Windows 11

Okay, I made the registry hack and am getting the context menu.
But I'm getting "no permissions" message when I try to use it. Even on a local (not network disc). I have sharing enabled.
Ideas.

This is Windows 11.

Which version do you use ...?
As ..:
[2021-10-23] NEW: added menu icon to Explorer context menu shell extension (requires restart to be
updated if already installed and in use).

(from the Changelog)

Which I would take that no more registry hacks are necessary.

update: uninstalled v3.11 and removed remaining registry entries that referenced it.
Installed v3.07 and everything works fine.

So maybe a bug with 3.11 and Win11?

As far as I understood that change, it made the feature more reliable...
So, what happens on your machine with the updated version?
And: do you have a standard or portable installation (see Help>About if you are not quite sure).

Have you restarted your machine and are you talking about context menu in Windows Explorer or in a third-party file manager?

Yes, restarted. Am talking about windows explorer.
But 3.07 is working properly.

And did you apply any registry tweaks to get the old context menu back on Windows 11?

I did a registry search for remaining lines with mp3tag in the registry after the uninstall of 3.11 and then deleted them.
After that installed 3.07 instead of 3.11. The older version works.

I've tried re-installing 3.11 and it doesn't give me the explorer right click feature.

3.07 does when I re-install it.

I'll wait for 3.12 and then try again.

I guess you didn't answer the question: are you using the new context menu of Windows 11 or did you apply any registry tweaks to get the old context menu back?

@firedog: It's about the new registry key {86ca1aa0-34aa-4e8b-a509-50c905bae2a2} as you can find it here:

I'm not using registry tweaks. I'm getting the context menu in Windows 11, but only if I install 3.07 instead of 3.11.
With 3.11 I don't get it.

Just installed 3.16 on Win11 64bit
Context menu has totally disappeared. Did standard install with all the options checked for install. Shut down and rebooted computer. No change.
Did reinstall no change.

Is there a fix?

Can you try restarting explorer.exe via right-click in Windows Task Manager and see if it appears?

If not, please make sure you have the latest from Windows Update.

If still not, check

powershell -c "get-appxpackage -name *mp3tag*"

from a command prompt with admin rights.

Hi-
Did all of the above. No change. Context menu still doesn't appear.
This is an ongoing issue now for a while over several versions.There should be a permanent fix.

You didn't tell what the PowerShell command produced as output.

Can you try from a command prompt with admin rights.

cd C:\Program Files\Mp3tag
powershell -c "Get-AppxPackage -name *mp3tag* | Remove-AppxPackage"
powershell -c "Add-AppxPackage Mp3tagShell.msix"

Microsoft Windows [Version 10.0.22000.708]
(c) Microsoft Corporation. All rights reserved.
C:\WINDOWS\system32>cd C:\Program Files (x86)\Mp3tag C:\Program Files (x86)\Mp3tag>powershell -c "Get-AppxPackage -name mp3tag | Remove-AppxPackage" C:\Program Files (x86)\Mp3tag>powershell -c "Add-AppxPackage Mp3tagShell.msix"

C:\Program Files (x86)\Mp3tag>powershell -c "Get-AppxPackage -name mp3tag | Remove-AppxPackage"

C:\Program Files (x86)\Mp3tag>powershell -c "Add-AppxPackage Mp3tagShell.msix"

C:\Program Files (x86)\Mp3tag>

Didn't appear to actually do anything. Got a message flashed as if it was trying on a blue background (not in Command prompt Window), but nothing actually appeared to be processing.
BTW, on my machine it installs in C:\Program Files (x86)\Mp3tag
What you wrote doesn't work.

@Florian-

No reply? Still not working for me

@florian

Hi-
uploaded an answer 13 days ago.
The PowerShell command ran but it appears nothing actually happened(see above).

I don't get a response?

It's hard to tell what's going on and I have no real idea on how to help you. It's working with all my Windows 11 test systems (well, except for the insider dev channel, but that's another story).

If you're interested in trying things, you can uninstall Mp3tag (either keep your configuration or make a backup, preferably both) and then reinstall.

If after restarting the explorer.exe via the Windows Task Manager, the context menu entry still doesn't appear, please send the output of

powershell -c "Get-AppxLastError"
and
powershell -c "Get-AppxLog"

While re-reading the whole topic, I've just noticed that those two are contradicting each other. Maybe you still have something in your registry, which interferes with the normal shell extension that is registered using the installer?