[WS] Discogs (pone mod)


#761

I applied the https and cover fixes described in the previous pages to the export files. So you can change your config settings in the "Discogs Pone 4 Web Script Settings.mp3", and regenerate working script files.

Follow the directions in the first post, but after Step 1., replace the "export" folder extracted from the zip with this one. Then continue to Step 2.

Or, if you already have it installed, you can go to %appdata%\Mp3tag\ and replace the "Discogs Pone Create" files inside the "export" folder with these ones. Don't replace the whole folder! There are other files already in "export" that need to stay there. Then follow steps 4-8 on the first page.

Use at your own risk! I don't completely understand how the scripts work. I tested most of the generated "search by" scripts, and they seem to download covers and all tags. If they erase all your music files and your computer bursts into flames, don't complain to me. Make backups, and wear sunscreen.

export.zip (47.8 KB)


#762

Quick check, seems to be working fine.
All missing fields and covers are downloaded.

Great Job. :w00t:

Thanks.


#763

Does not work.


#764

I followed the instructions on the first page of this post but i am not getting the expected results. My files have fields: Title, Artist, and AlbumAritst. I am trying to add Album and Genre. Here are the steps I have taken if someone is willing to walk me through this I would greatly appreciate it.

  1. Add Directory (point to files i want to update)
  2. Select All Files
  3. Action Group --> Discogs Pone --> Update Settings MP3 File
  4. Extended Tags --> Leave Title, Artist, and AlbumArtist as and change remaining tags to
  5. Action Group --> Discogs Pone --> Create Scripts
  6. Tag Sources --> Discogs Pone --> Search by (Album)Aritst + Title
  7. Select an option from the albums provided and click next
  8. The "Adjust tag information" window is shown but there is only data in the Tracks section
  9. Click Ok
  10. Receive message "0 of 0 Tags updated"

#765

It sounds like you're adusting things in the Tag Panel on the left. Instead, you need to click the "Extended Tags..." button in the toolbar. That pops open the tag editing window, and in it you'll see a lot of crazy-looking text. Choose one of the fields and click the "Edit Field..." button, and another window pops up. Then you have to try to figure out what all the options mean. It's not so user-friendly.

But I didn't see any options in there, where you can say which fields you want changed, and which not. Maybe there's another way in Mp3tag, I'd also like to do that. So far I haven't figure it out, but I've only been using it a couple of weeks...


#766

You said earlier you tried doing the "replace all http with https" fix and it didn't work for you. It seems to work for everyone else though. It sounds like maybe something else is messed up in your setup.

Does the regular (non-Pone) Discogs search work for you?

Maybe try backing up your "Discogs Pone 4 Web Script Settings.mp3", and reinstall the Pone mod, with the updated export files?


#767

Hallo pone,

habe (erst jetzt!) deine Scriptsammlung entdeckt.
Vielen Dank dafür.

ist das die aktuelle Version, oder gibt es schon was Neueres?

Danke
Jo A. Kim


#768

I just tried & still couldn't get Pone to work; Regular Discogs works, but Pone fails with '404 unauthorized' etc...

Also, I'm always reluctant to update mp3tag versions as every time Discogs auth stops working.
Sometimes it can get it to work by mucking around with complete uninstalls and registry remnants removals, but sometimes it still doesn't work.
I've got 3 computers using mp3tag (mine, wife's & work's), and only one still works with Discogs.
1 PC sometimes will suddenly then work but 1 PC now hasn't worked for months, just gives the same as Post #763.
3 different discog accounts too, so it's not like the API keys are getting messed up.

So annoying how the folks at Discogs seem to be changing things (I assume).

It's great so many folks here are trying to get it all sorted.

I'm totally lost when it comes to the scripting language, so I don't touch anything... I just hope one day everything works like it used to back in the day (before Discogs changed authentication methods :angry: etc)


#769

Sorry morts, I don't know what to say... Pone v4.4, after replacing the export files and doing the "create scripts" action, is working fine for me. I only had to authorize once. Using mp3tag v2.75.


#770

Hi there,
For those how don't like to read all the post to get pone script working again I claim all information and put in one working file.
For me it work perfect :stuck_out_tongue: but use it one your own risk.
Follow the first post to install.

Discogs_Pone_Mod_4.4_update.rar (48.8 KB)


Pone Script Update? Album Artist
#771

Can confirm - works great! Many thanks.


#772

Thank you very much! Your update file worked perfectly for me!
Kudos!


#773

Hello Elhem and thank you for the reply.

Updated Mp3tag to the latest 2.77 version, updated script using the one provided by jokertest on Post #770 and I'm getting the following error at the regular (non-Pone) Discogs search:

Any help is greatly appreciated.

Edit: I believe that I've found myself the root cause on this post. Translated:

"Unfortunately, Windows XP (and Server 2003, my scenario) does not support SSL on TSL 1.2, so that access to the Discogs API by Windows XP can unfortunately no longer be supported now."


#774

What now? Running Win 7 not XP.




#775

I'm now getting the same error as Blackbeen.
v2.77 on win 7
worked fine yesterday - now getting:

 Failed to authenticate using OAuth (1)
12175: 12175:  a Security error occurred

any Ideas?

is there a way to reset/delete discogs token?


#776

ditto. Getting the same error message. Discog's api still works since I can still browse it using my personal token (https://www.discogs.com/settings/developers).

However, after removing mp3tag's authorization (Logged into Discogs > Settings > Applications), mp3tag no longer prompts for an authorization code nor is the discogs application authorization page brought up.


#777

Same error here with all Discogs scripts since today, including the regular 'built-in' Discogs Tag Source.
Ver. 2.75/Win7


#778

Today with pone:


Default Discogs script is working again.

Ver. 2.77/Win7



#779

Yes, but this script is virtually worthless, id rather just manual tag.


#780

Same issues as above few posts: failed to authenticate using OAuth - 403: forbidden

Tried deleting current access key in discogs and reset mp3tag, but still returning the same issue.

Is it something Discogs side, they seem to keep changing it; what with cover art issues before with the scripts and now this!


No results with pone / discogs script