[WS] Discogs (pone mod)


#781

Try to put
[UserAgent]=1
juste after the line [Encoding]=utf-8 in the head of the file.


#782

None of that is found in Discogs__Pone__Direct_by_Discogs__ID.


#783

Just try after the line:
[SearchBy]=$if2(%DISCOGS_RELEASE_ID%,$if2(%DISCOGS_RELEASE_ID%,$if2(%DISCOGSID%,%DISCOGS-ID%)))


#784

Sadly, this didn't work for me; still getting 403: Forbidden.
EDIT: Nevermind it works, thanks!
I was accidently editing the .mte file in 'export' rather than the .src file in 'data\sources'.
Thanks again.


#785

Works for me in both the Pone Updated script and the Mp3tag Discogs script. Thanks for the solution.

Gary


#786

Thanks!


#787

Also worked for me. Many thanks.


#788

This ultimately proved to be the solution for me, thank you very much! Great share to help all get resolved.

I recently updated my Pone scripts following:

And it was working perfectly fine for me up until yesterday, although a few other members here spotted it beforehand.

Something changed again?

Also, in the updated scripts I run, "[UserAgent]=1" is not in the file at all, it needs to be manually added in for all those who hit similar issues.

Mp3Tag tags native Discogs script has this in there already.

Also, slight side note, but how come Pone's updated scripts can now bring in coverart, but the native mp3tag doesn't?


#789

Thank you so much for the solution, clouseau!
Inserting
[UserAgent]=1
in the script made it work again.


[F] Discogs - Error >> 401 : UNAUTHORIZED
#790
QUOTE

Same for me. This is great information. I am back up and running. I dont know what Id do without ponemod working.

To be VERY CLEAR for those who may not fully understand and are still having problems, THIS IS WHAT YOU NEED TO DO:

STEP 1: download the updated scripts, kindly posted by @jokertest -- then, install it by following the instructions on the first post of this thread (OP), and be sure NOT to overwrite your custom settings in the mp3 file (it explains this in the instructions!). After you re-generate the scripts (Step-7 of the install/update instructions), you must manually edit the search scripts...

STEP 2: following the instructions posted by @clouseau -- you must manually open each of the search scripts that you want to use, located at %appdata%\Mp3tag\data\sources. How do you know which ones you need to edit? Well, you look for the name of the script that corresponds to the search method that your prefer to use. For example, I primarily only use the "Search by (Album)Artist + Album" and the "Direct by Discogs ID" search methods.. so these are the only two scripts that I modified (i dont care if the others work, since I never use them). So, now you open the file you want to edit, using a text editor (i.e. Notepad, SublimeText, Notepad++) and add the "[UserAgent]=1" (without the " " quotes) on a new line. Place it directly under the line that begins with "[Encoding]". If a line does not exist that begins with [Encoding], look for the line that begins with "[SearchBy]", and place it under that. Save. Restart MP3Tag. Test. It should work fine, using any of the search methods that you manually altered in Step 2.


#791

Hi Music Friends,
again how is lazy or don't no wow to do i make a new update. for me it work fine :laughing:
so use it by your own risk.

Follow the first post to install.

Discogs_Pone_Mod_4.4_update.01.rar (49.1 KB)


[AF] Problem mit dicosgs
Search by Artist (Discogs Filter)
#792

Would it be possible and potentially worthwhile for all if Florian could integrate the Pone Mod scripts into the application?


#793

I forgot to post a day after my original post: it suddenly started to work fine.

But then today, I got the same as everyone else...
Such a bummer.... :frowning:


#794

Hi Morts,
this i can not confirm. For me pone script works perfect.
Try to use my updated pone pone to us it.


#795

Many thanks Joker - I did as you suggested (got the new scripts) and all works!
:slight_smile:

Thanks again!


#796

You're a champ jokertest! All working perfectly now.


#797

Hi guys,

I was having problems lately so I came here and follow all the latest instructions by jokertest. Looks like everything works again except for the cover which is not showing. Anybody has an idea about what I can be doing wrong? Thanks!!


#798

Covers should work, except with the "Direct by URL"-Script.
Never got it to work with the old scripts or the new updated ones.


#799

Haha, thanks, I was a "Direct by URL" type of guy. :wink:
I'll now use the "Direct by Discogs ID" option.

Thanks again!


#800

~