[X] Error beim Wählen vom Album Cover

Hallo,

seit dem Update auf Version 2.69 kann ich kein Album Cover mehr wählen oder speichern. In der Mp3tagError.log steht das Folgende:

--------------------------------------------------------------------------------
THROW
--------------------------------------------------------------------------------
File:        mtcoverhelper.cpp
Line:        178
--------------------------------------------------------------------------------
CATCH
--------------------------------------------------------------------------------
File:        mtcoverhelper.cpp
Line:        239
================================================================================

Ich nutze Mp3tag unter Debian Linux mit wine 1.6.2.
Da ich mit vorherigen Versionen nie Probleme hatte, hoffe ich, dass die Problemursache leicht zu finden und zu beheben ist.

Da es manchmal so ganz seltsame lokale Fehler gibt: probier mal, ob eine neu angelegte mp3tag.cfg Datei hilft (also Mp3tag beenden, mp3tag.cfg umbenennen, mp3tag neu starten). Falls das nichts hilft, kannst du die neu angelegte mp3tag.cfg wieder löschen und die alte in mp3tag.cfg zurück umbenennen.

Danke für die schnelle Antwort, behebt den Fehler aber leider nicht <_<

Wenn du eine ältere Version installierst, ist dann der Fehler weg?
Wenn der jetzt auch da auftritt, müsstest du mal gucken, ob die Benutzerrechte stimmen.

Ja, ältere Version drüber installieren und alles funktioniert bestens. Nur bei Version 2.69 und 2.69a tritt der Fehler auf.

Also einen lokalen Fehler kann ich relativ sicher ausschließen, da ich gestern Debian komplett neu aufgesetzt habe und den Fehler weiterhin bei den Versionen 2.69/2.69a und 2.70 erhalte

Hier gibt es eine Rückmeldung eines anderen Wine-Anwenders
!BAD ID3v2 nach Update von 2.51 auf 2.70

Dessen Urteil fällt anders aus ...

Danke für den Hinweis, sehe aber keinen Widerspruch in dem Urteil bzw habe mich vllt nicht klar ausgedrückt. Davon, dass die Versionen unter Windows / in einer VM funktionieren und es mit der Nutzung von Wine zusammenhängen muss, gehe ich aus.
Jedoch muss diese Inkompatibilität mit einer Änderung in Version 2.69 zusammenhängen, daher meine Hoffnung, dass sich das Problem leicht lokalisieren lässt und die Änderung eventuell anders umgesetzt werden kann um die Nutzung auch unter Linux (evtl. ist auch Mac betroffen?) weiterhin zu ermöglichen. Dass dieses Problem nur einen verschwindend geringen Anteil der Nutzer betrifft und daher auch nicht die höchste Prioriät hat, ist mir natürlich bewusst.
Sollte es sich nicht beheben lassen, werde ich die alte Version benutzen und darauf hoffen, dass es irgendwann durch ein Wine-Update behoben wird.

Muss mich korrigieren, habe gerade Version 2.68 heruntergeladen und da besteht der Fehler auch. Version 2.66 funktioniert. Version 2.67 habe ich leider keinen Download zu gefunden, vermute aber, dass ich die vorher genutzt habe, da ich eigentlich immer geupdatet habe und vermutlich keine zwei Versionen übersprungen habe.

In dem schon genannten Thread
!BAD ID3v2 nach Update von 2.51 auf 2.70
gibt es neue (15.5.2015) weitere Informationen.

Vielen Dank für den Hinweis, mit der Development Version läuft es bei mir auch :slight_smile: