Directory clears after tag change

When editing files all in the same directory, once a tag change on any file in any field is saved, all of the files in the directory disappear from mp3Tag except for the file changed.

I've been using mp3 tag for a long time and I've never seen this behavior.

Could you elaborate a little more on how to reproduce the behaviour along the guiide lines of this post:

MP3Tag Versions: 3.23 and 3.23c

Condition: multiple songs in any single directory (also happens when songs are in adjacent sub directories)

Action: Update and save any single tag for any single song.

Expected Behavior: Tag is saved, no other song is affected.

Actual behavior: All other songs disappear except for the song being updated.

Corrective action: All songs must be re-imported from directory.

Repeatable: Happens every time under the above conditions regardless of directory.

You are right - this is what I would have expected.
And this is exactly what I get.
I tried updates of files while a filter is set - but that leaves the file list as it was prior to editing, i.e. all the files stay there and do not need to be reloaded.

Does this happen on 2 different PCs?
Where are the files located? Locally or on a NAS?

Here it is in action.

And this is exactly what I get.
It's what I usually get. This is the first time I've ever experienced this.

Does this happen on 2 different PCs?
Don't have another to test on hand

All files are local.

I see.
But I don't know why it happens.

So: could you save the current configuration and save it in a safe location,
de-install MP3tag completely with all the settings and configurations,
install MP3tag in a fresh, untouched state
and try the same manipulation with that version.
And if that installation works as expected, restore the saved previous configuration and see what that does?

I tried that, actually. No joy. I didn't restart in between though, so there may have been some ghosts in the machine. I'll do it fully clean to see what it does.

Can you, by chance, indicate what might have changed on your system between Mp3tag working correctly and the described behavior?

Is the Filter field visible and if so, does it also happen if you hide the Filter field via F3?

1 Like

I just remember this thread:

and this one: